electron 高版本所遇到的iframe跨域问题

近期在接触electron项目中,发现iframe引入链接会有跨域问题,导致iframe内页面无法接收到参数。而老版本(4.x)未发现这个问题。经过多方排查,确认electron自5.x之后更新了安全策略,遵守同源策略。而 webSecurity 无法对 http/https 页面进行修改。最后找到如下方案,即可解决:const { app } = require('electron'); app

- 阅读全文 -

macOS Catalina(卡特琳娜) electron-builer 打包 electron 应用程序相关问题

在最开始升级卡特琳娜之后,使用electron-builer 打包就各种报错(报错信息已无法找到),后各方找资料之后,知道了这是卡特琳娜不再支持32位应用程序了,而electron-builer 是使用32位进行打包的。得,等吧。之后将 electron-builer 更新到 22.2.1 之后,mac版本终于成功的打出来了,然后 electron-builer --winBooooooooooo

- 阅读全文 -